Network Routing Issues
Incident Report for Velocity Host Status Page
Postmortem

Addressing all (vh) clients

Thank you for your patience in awaiting this postmortem of last weeks incident.

Overview:

On the 7th April 2020 approximately 1:30 pm (13:00) we started seeing intermittent random spurts of traffic latency across our public network.

The issue was presenting as slow traffic pings for approximately 6-10 min at a time disrupting connections to Data Center traffic inbound / outbound.

At the time of the issue our team had presented a list of possible causes and started to action steps to troubleshoot each possibility.

As the day progressed the latency interruption became less disruptive as occurrences where spread further apart eventually stopping at approximately 9:30 pm (21:30).

Unfortunately we where unable to pinpoint the root cause of the issue at the time due to the inconsistent nature of the events but had setup additional monitoring and continuity plan in the event the issue returned.

Follow Up Event:

5 days had passed without re-occurrence until Sunday April 12th approximately 5pm (17:00), with previous monitoring already in place and more preparation we where able to determine the root cause was a DDOS DNS amplified attack targeting a clients VM which had firewalls turned off at the time.

This DDOS attack caused a slowdown in network traffic and was outbound from (vh) public facing services.

Service Improvements

To minimize further disruptions our team has performed and put in place the following:

  • Additional bandwidth throttling measures for direct to public traffic and public facing services
  • Additional triggers and alarms have been created to monitor client public traffic throughput hitting maximum allowed levels i.e. 70%, 80%, 90% of allowed throughput will alert our team and pinpoint the service abusing shared bandwidth.
  • Direct to Public and vCloud traffic have been split into two separate networks to minimise disruption across public, private and hybrid network spaces.

If you have any questions on the postmortem please feel free to open a support ticket in the (vh) cp platform https://control.velocityhost.com.au and use "April 7th postmortem" in the subject field.

Enjoy the rest of the Easter long weekend and thanks again for your patience.

Kind Regards
(vh) Admin Team

Posted Apr 13, 2020 - 10:25 AEST

Resolved
This incident is being marked as resolved at this time.

Thank you for your patience while we worked through the processes involved to safely resolve this issue.

(vh) Admin Team
Posted Apr 08, 2020 - 18:56 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2020 - 22:15 AEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 07, 2020 - 21:08 AEST
Update
We are continuing to work on a fix for this issue, we will update again in 1 hour.

Thank you
(vh) Admin Team
Posted Apr 07, 2020 - 20:28 AEST
Identified
Our team is planning a series of troubleshooting steps scheduled in for this evening starting after 6pm, we will continue to monitor the affects of each change before applying the next round of troubleshooting.

Thank you for your patience.
(vh) Admin Team
Posted Apr 07, 2020 - 16:22 AEST
Update
A layer 3 routing issue has been identified for up stream traffic, our team is still investigating and implementing incremental planned changes to isolate the issue further.

Please keep an eye on our status pages for further updates.

Thank you.
(vh) Admin Team
Posted Apr 07, 2020 - 15:40 AEST
Update
We are continuing to investigate this issue.
Posted Apr 07, 2020 - 13:38 AEST
Investigating
Currently experiencing network routing issues, under investigation.
Posted Apr 07, 2020 - 13:13 AEST
This incident affected: Micron21 DC Public Network.